No bindable control for action

Sep 17, 2010 at 6:29 PM

Hi Im using Caliburn Micro in a silverlight 4 app. I have noticed whenever I activate a view model my output gets spammed with "No bindable control for action" messages. 

[2010-09-17T10:23:02.0302846-07:00] Binding MyApp.Views.Shared.ShellView+MyApp.ViewModels.Shared.ShellViewModel.
[2010-09-17T10:23:02.0342848-07:00] Setting DC of MyApp.Views.Shared.ShellView to MyApp.ViewModels.Shared.ShellViewModel.
[2010-09-17T10:23:02.0352849-07:00] Attaching message handler MyApp.ViewModels.Shared.ShellViewModel to MyApp.Views.Shared.ShellView.
[2010-09-17T10:23:02.0362849-07:00] Attaching MyApp.Views.Shared.ShellView+MyApp.ViewModels.Shared.ShellViewModel.
[2010-09-17T10:23:02.0402852-07:00] No bindable control for action set_CloseStrategy.
[2010-09-17T10:23:02.0412852-07:00] No bindable control for action get_CloseStrategy.
[2010-09-17T10:23:02.0412852-07:00] No bindable control for action get_ActiveItem.
[2010-09-17T10:23:02.0422853-07:00] No bindable control for action set_ActiveItem.

The output continues for the rest of the viewmodels properties

ShellViewModel inherets from conductor. The other viewmodels have simmilar issues, the inheret from IScreen

public class ShellViewModel : Conductor<IScreen> {

}

What am I doing wrong, and/or, how can I shut up my output

Thanks in advanced

Coordinator
Sep 17, 2010 at 7:02 PM

I'm assuming that you installed a logger in order to see this. You could just add a little code in there to filter out things that start with "No bindable"

Sep 17, 2010 at 7:39 PM

Yep, that was it.