Problem with Silverlight Project Template

Oct 16, 2010 at 3:59 PM

I just tried installing the Silverlight project template, and ran into an obscure error dialog:

I did a search online and found this thread:

Looks like a bug in VS2010, but can be fixed by using "$projectname$" instead of $safeprojectname$.

I did what was suggested but am still getting the error.  Has anyone else run into this problem?

Oct 16, 2010 at 4:42 PM

I've been using the templates a lot and I haven't run into this. Nevertheless, I will definitely investigate.

Oct 16, 2010 at 4:52 PM


I'm not able to reproduce the problem.

Does this always occur for you? or are there specific conditions? Also, what version of VS are you using?



Oct 16, 2010 at 4:57 PM

Yes. Always. I switched my directory structure to read “Caliburn” from “Caliburn.Micro” (thinking the “.” Was the problem) and was still getting this error.  VS2010 Ultimate (on Windows 7 x64).

I just tried using the WPF version of the template and ran into the same exception, only this time with AssemblyInfo.cs.

Oct 16, 2010 at 5:33 PM
Edited Oct 16, 2010 at 5:42 PM

Okay, my setup is the same. Win7, x64 with VS2010 Ultimate. 

Are you building the templates with the latest source?

I'm copying the zip files to this location:

C:\Users\Christopher Bennage\Documents\Visual Studio 2010\Templates\ProjectTemplates\Visual C#\Caliburn\

Oct 16, 2010 at 5:38 PM

Since I can't repro, perhaps you can test a fix for me.

  • Pull the latest
  • Do a search and replace on all the files in  \templates. Replace $safeprojectname$ with $projectname$. There should be 39 occurrences in 21 files.
  • Run the generate-templates.ps1
  • Test the new templates.


Oct 16, 2010 at 5:39 PM

I am indeed using the latest source.  I am not using a sub-directory, but my templates have been moved to my D:\ drive.  I bet you that is what is causing the problem.

Oct 16, 2010 at 5:46 PM

Hm... is there an application you have in mind for search and replace?  I'm using Visual Studio and I only get 11 matches in 4 files.

Oct 16, 2010 at 6:00 PM

AHhhhhhhh... ya know what, that was it!  I didn't generate the templates... just tried zipping up the contents and using that.  I didn't realize there was a generator (was wondering what the Solution was for. :P ).  I guess I am used to looking for .bat and .cmd files.  Now I'll look out for .ps1 files from now on. :)

Oct 16, 2010 at 6:05 PM


Maybe I should add a readme (or even a bat file to run the PowerShell script).